Well that was quicker to fix than I thought.
The solution was to change "Startup - Default profile" to "Command Prompt" and "Startup - Default terminal application" to "Windows Console Host", not "Windows Terminal"
The bad screens were running under "Windows Terminal"
If you are running under Windows Terminal you get to where you can change it by the downward facing arrow on the screen and picking "Settings"

If you are running in Windows Console Host mode and want to change to Windows Terminal you get there by upper left, right click Properties, click the Terminal tab and at the bottom change the Default Terminal Application.