Results 1 to 2 of 2

Thread: Quill Editor - Bug or Feature?

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2009
    Location
    Adelaide, South Australia
    Posts
    471

    Default Quill Editor - Bug or Feature?

    I have just implemented the Quill editor in a development workspace to test prior to production. I had assumed that setting pbUseHTMLEncoding to True would automatically save formatted text as html. It doesn't. If I click the HTML button it shows the html formatting in the Editor. Saving the record while the html is showing works and writes the html into the database.
    Requiring staff to always remember to click the html button prior to saving is too big an ask.

    Does anyone have a workaround for this?


    Ian

    Edit: I guess it's a bug but I have found two work arounds.
    The default setting in cWebRichTextEditor.pkg is
    Code:
            {WebProperty=Client}
            Property Boolean pbUseHTMLEncoding    False
    Changing that to True will fix it which I guess is OK if you always want to save HTML.
    The way I chose, however was in the Save button.
    Code:
            Object oSaveBtn is a cWebMenuItem
                Set psCSSClass to "WebSaveMenuItem"
                Set psCaption to "Save"
    
                Procedure OnClick
                    WebSet pbUseHTMLEncoding of oProdinfo to True  // This forces an HTML save on saving
                    Send Request_Save
                End_Procedure
    
            End_Object
    Last edited by Ianv; 30-Nov-2021 at 11:27 PM.
    The most important leg on a three legged stool is the one that's missing.
    Murphy's Law (2)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •