We hit the 10g limit with a non-DataFlex application and it does not throttle, it completely stops, at least wringing new records is not possible anymore.
Also: The files can be 10G large without any problem. You can add new records as long as there is enough free space in the files (keep in mind: if you store large binary blobs in the database, smaller records may be added, but the blobs fail. This may lead to all sort of funny behaviour...).

The increasing file size might be relate to something temporary. Large amounts of data stored in a temporary database to calculate something (monthly totals, statistics, ...).

If things get slow it is worth checking if the indexes are proper and the database is in a good state. A reorganisation/rebuild might help.
Check the docs: https://docs.microsoft.com/en-us/sql...l-server-ver15

Also note, if you already do/did this:
The ALTER INDEX REORGANIZE statement requires the data file containing the index to have space available, because the operation can only allocate temporary work pages in the same file, not in another file within the same filegroup. Even though the filegroup might have free space available, the user can still encounter error 1105: Could not allocate space for object '###' in database '###' because the '###' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup during the reorganize operation if a data file is out of space.