Sam,

Looks like your code is finding some old packages it should not find and your code is probably not self-containing (the use of USE statement in the top of each component). For that check the problem resolution panel.