After a few wrong turns...
Downloaded a fresh copy using the package manager. Deleted the embedded zip.
I didn't regasm the new download.
Sample worked okay.
Added my LibXL Licence keys.
Sample again worked okay even though its still Mike's LibXL and dlls in the programs folder.
AND specifying a decent key gets rid of the warnings on line one of the output samples, even though they key doesn't match.
Copied my LibXL-supplied LibXL.dll into programs. Comm error 4399
Copied my LibXL-supplied into programs. Runtime error 'runtime newer than currently loaded runtime'
C:\Users\DAve.KIRKFREEPORT\Desktop\StarZen.LibXL\P rograms\LibXLSample.exe
COM object method invocation error. Could not load file or assembly ', Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

Error: 4399

GET_COMCREATEBOOK (10381) - oLibXL (225) - at address 70893
GET_CREATEBOOK (10423) - oLibXL (225) - at address 71310
MSG_ONCLICK (4659) - oButton3 (227) - at address 71371
MSG_COMMAND (648) - oButton3 (227) - in native code
[start] - at address 71546

So, does szLibXL.dll need to be rebuilt for later versions of LibXL?