Hi,

Today I moved my working RESTful services locally onto a production server for further testing. All my verbs, GET, POST and PATCH work except DELETE.

I've combed everywhere, that I can think of, to see if there is something I've missed. The .WSO has all the verbs defined. I have even tried some others - HEAD - just to pass the time. Server has been rebooted but still no delete.

The message returned to POSTMAN is:

Code:
<fieldset>

<h2>405 - HTTP verb used to access this page is not allowed.</h2>
<h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to
                    attempt access.</h3>
</fieldset>


As far as I can tell the module request restrictions are correct i.e. DELETE has been defined as acceptable.

Click image for larger version. 

Name:	2020-09-11_17-23-38.png 
Views:	55 
Size:	103.1 KB 
ID:	13951

And the web.config also looks correct.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <location path="rest">
        <system.webServer>
            <dataflexHttpModule application="TriumphWS-6.2" enabled="true" object="oTriumphAPIs" verbs="GET,POST,DELETE,PATCH" errortype="0"></dataflexHttpModule>
        </system.webServer>
    </location>
    <system.webServer>
        <handlers>
            <remove name="DataFlex 19.1 Web Services 32bit" />
            <remove name="DataFlex 19.1 Web Services 64bit" />
            <add name="DataFlex 19.1 Web Services 64bit" path="*.wso" verb="GET,POST,DELETE,PATCH" modules="IsapiModule" scriptProcessor="C:\Data\DataFlex 19.1\Bin64\waswsvc.dll" resourceType="Unspecified" requireAccess="Script" preCondition="bitness64" />
            <add name="DataFlex 19.1 Web Services 32bit" path="*.wso" verb="GET,POST,DELETE,PATCH" modules="IsapiModule" scriptProcessor="C:\Data\DataFlex 19.1\Bin\waswsvc.dll" resourceType="Unspecified" requireAccess="Script" preCondition="bitness32" />
        </handlers>
    </system.webServer>
</configuration>
Is there anything else?