Roel,

In the MySQL DSN setup in ODBC Administrator there is a checkbox "Enable automatic reconnect". Try turning that on.