This took some figuring out, in my test environment I saw different results. It turned out that one of the ASP include files was stored as UTF-8 with BOM which made the ASP engine changes its output codepage to UTF-8. Luckily you can also control this from source code by setting Session.CodePage. Setting that to 65001 (UTF-8) stops ASP from converting the output to ANSI. You might also want to set Response.Charset.

So add the following code to the top of your ASP file:
Code:
<% 
    Response.Charset="UTF-8"
    Session.CodePage = 65001
%>