Results 1 to 4 of 4

Thread: Probleme mit Crystal Reports 8.5 auf Windows 10 64 bit

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Probleme mit Crystal Reports 8.5 auf Windows 10 64 bit

    Hallo,

    meine VDF 16.0-Anwendungen laufen auf W10/64bit einwandfrei; auch die Reports die aus der Anwendung heraus gestartet werden, funktionieren.
    Versuche ich jedoch einen Report mit CRW 8.5 zu ändern,aktualisieren oder neu zu erstellen, erscheint die Fehlermeldung "p2bdfapi.dll nicht gefunden"
    obwohl diese dll in den Verzeichnissen ..VDF16.0/bin und CrystalReports/DeveloperFiles/lib und /include vorhanden ist.

    Woran kann es noch hängen - bin für jeden Tipp dankbar!

    Viele Grüße

    Harald

  2. #2
    Join Date
    Feb 2009
    Location
    Hengelo, Netherlands
    Posts
    9,015

    Default Re: Probleme mit Crystal Reports 8.5 auf Windows 10 64 bit

    Harald,

    Crystal 8.5 was created about 20 years ago (see https://en.wikipedia.org/wiki/Crystal_Reports). I would be surprised that it runs these days with the thousands of OS updates over the last 20 years.
    Regards,
    Data Access Worldwide
    Vincent Oorsprong

  3. #3
    Join Date
    Jul 2009
    Location
    Wiesbaden, Germany
    Posts
    218

    Default Re: Probleme mit Crystal Reports 8.5 auf Windows 10 64 bit

    Was man noch probieren könnte wäre, Crystal mit der rechten Maustaste als Administrator zu starten. Vielleicht funken ja lokale Sicherheitsrichtlinien irgendwo dazwischen.

  4. #4
    Join Date
    Feb 2009
    Location
    Niedernhausen, Germany
    Posts
    153

    Default Re: Probleme mit Crystal Reports 8.5 auf Windows 10 64 bit

    Wie Vincent schon erwähnt hat, ist CRW 8.5 mittlerweile fast 20 Jahre alt. Mit DataFlex Reports gibt es ein Produkt, was ähnlich funktioniert und was sehr gut in DataFlex Programme zu integrieren ist. Auch die Web Integration ist sehr einfach und es gibt entsprechende Assistenten, die kompletten Code generieren.
    Um das alte CRW noch zum Laufen zu bringen, kann man nur probieren: Z.B. das Programm einmal mit Admin-Rechten starten (Rechte Maustaste: "Als Administrator ausführen"; oder den Prozess-Explorer starten und dort schauen, ob man sehen kann, was evtl. fehlt; oder die Programme und Treiber komplett neu installieren, oder....

    Viele Grüße
    Matthias Burkhardt
    Last edited by Matthias; 17-Feb-2020 at 03:03 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •