Results 1 to 3 of 3

Thread: Request Save inconsistency?

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Request Save inconsistency?

    I have a Dataflex 19.1 mobile touch app with two drill-down zooms
    Each of them have a cWebButton whos on-click event contains the following:

    Code:
    Move iNumber to Table.Field
    Send Request_Save of oTable_DD
    The first one works. The second doesn't. There are a few minor differences, so I tried removing them.
    1. The broken one has a cWebForm bound to Table.Field. I commented it out, and the problem persists.
    2. The broken one uses a variable while the working one uses an explicit value. I switched to an explicit number with no luck.
    3. The broken one calls the change within a callback to a callback (I wanted two different confirmation dialogs for two potential issues). Placed it right at the start of the onClick event. Still no dice.

    What else could be causing it? There's no trigger or anything database side causing the problem because I can change it with a simple update query in SQL, and the two fields are of the exact same data type. No error is being thrown, just the value in the buffer is reset instead of being committed. If I can't work it out I'm gonna have to do something stupid like write a SP and put in code to call *that* from the application.
    Last edited by IsaacReefman; 13-Feb-2020 at 03:34 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •