I downloaded the doc and DF-20 Studio and the installation went quite smoothly though I didn't get to set where the examples are installed. Hopefully that will get fixed at some point.

I had to fix one compiler issue that was present in 19.1 and then my fairly large 19.0 application compiled. I tried it in both 32-bit and 64-bit and only had to change two integers in one package to LongPtr for the 64-bit compile to complete.

My database is in Postgres, using the Mertech driver so it won't run though I'm not sure why, I copied the drivers over. I would think that it would just work in 32-bit but maybe I missed something. I could go through the lengthy exercise of converting the database to the embedded and then to MSSQL but too lazy this afternoon.

When I attempted to run the app in 32-bit I did encounter one error that might actually be a DAW error. This occurs in cToolTipController.pkg on line 94.

C:\VDF-20.0\Projects\National-PROD\Programs\Main.exe
Number too large to convert to integer

Error: 4135

SET_PBBALLOONSTYLE (8208) - oToolTip (36) - at address 47947
[start] - at address 84732
And I see that the mouse scroll wheel still doesn't work in the Quick find window or whatever it's called. Is that really so hard to do? We've only been asking for it for what, 3 years?

Click image for larger version. 

Name:	mouseWheel.jpg 
Views:	64 
Size:	23.7 KB 
ID:	13230

Anyway, all went pretty well all things considered. Back to reading the doc...