Hi Larry

From my PoV, this is a moot point.

When testing for the "implicit" true/false nature of a variable, I prefer it to be explicit: If (iTest <> 0) ..., but I see no virtue in simply wrapping as an expression: If iTest vs. if (iTest).

Such a reliance on "implicitness" I am even less happy with when it is not even an integer which is being tested: If sTest... which I think should always be written If (sTest <> ""), but others may have different opinions.

OTOH, when the true/false nature is "explicit" (as with a boolean) I see no problem with the simple If bTest ...

Mike