Results 1 to 10 of 11

Thread: Error deploying libsodium

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Error deploying libsodium

    We are trying to deploy an application that uses libsodium, but we get an error

    Webapp.exe refuses to start because of this error:

    The webserver is a Windows 2012, and we have installed the C++ 2017 runtime that came in the libsodium library:

    If we try to register libsodium.dll (as admin) we get the following error:

    But the api-ms-win-crt-runtime-l1-1-0.dll file is part of windows update KB2999226, that was installed with the
    C++ 2017runtime we just installed.

    We also tried to reinstall C++ runtine, run repair, and reboot of the webserver withoutluck.

    Even tried to install the 64bit C++ runtime also, but still the same error.

    Any suggestions?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	libsodiumerror1.jpg 
Views:	488 
Size:	124.6 KB 
ID:	13165   Click image for larger version. 

Name:	libsodiumerror2.jpg 
Views:	444 
Size:	5.1 KB 
ID:	13166   Click image for larger version. 

Name:	libsodiumerror3.jpg 
Views:	454 
Size:	32.3 KB 
ID:	13167  
    Last edited by JimmyH; 21-Oct-2019 at 02:17 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts