I tried to uninstall 2017 and install 2015, but Im getting an error:

Error 0x80240017: Failed to execute MSU package.

Maybe this 2012 Server is unable to run C++ runtimes newer than 2013?