Sean mentioned in this thread the idea of using (-1) as the index for append to array I'd just like to second that.

Code:
 
  Move hoItem to aXRefRows[iTheRow].hoItem[SizeOfArray(aXRefRows[iTheRow].hoItem)]
Would be much more better written as

Code:
 Move hoItem to aXRefRows[iTheRow].hoItem[-1]