Results 1 to 4 of 4

Thread: Strange problem with manifest file and szLibXL

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #2
    Join Date
    Feb 2009
    Posts
    726

    Default Re: Strange problem with manifest file and szLibXL

    I erased libxl.dll, libxl.net.dll and szLibXL.dll from the DataFlex 18.2\bin map, re-compiled and then it worked with the manifest files I already had.

    The libXL.dll file from StarZen Package client is version 3.6.5.0 from 2016-07-16, but it seems to work with the latest version 3.8.4.0 which I just downloaded from Libxl. This new file is much bigger than the old one.

    The szLibXL.dll file I use is version 1.1.0.0 from 2018-10-17. I copied the lines below from LibXLSample.exe.manifest to my manifest files, and that worked. In another thread, MisterM wrote that the version no should be changed to 1.0.0.0, but if I do that, the program doesn't start and states that the side by side configuration is wrong.

    Code:
        <dependency>
            <dependentAssembly>
                <assemblyIdentity processorArchitecture="msil" name="szLibXL" version="1.0.0.0"></assemblyIdentity>
            </dependentAssembly>
        </dependency>
    Last edited by Bengt; 31-Mar-2019 at 01:35 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •