DataFlex 19.1 Beta 2 has a changed ODBC driver that should work with the latest MySQL and MariaDB versions and MySQL/MariaDB ODBC drivers.

We tested with the following environments:

MySQL
Latest MySQL versions (server and ODBC connector) can be downloaded here: https://dev.mysql.com/downloads/
Tested MySQL version:
MySQL 8.0.13 Community server 8.0.13
Minimum required MySQL ODBC driver version:
MySQL ODBC 8.0 ANSI Driver Version 8.0.13 (mysql-connector-odbc-8.0.13-win32.msi)


MariaDB
Latest MariaDB versions (server and ODBC connector) can be downloaded here: https://downloads.mariadb.org/
Tested MariaDB version:
MariaDB 10.2 Series
Minimum required MariaDB ODBC driver version:
MariaDB Connector/ODBC 3.0 Series 3.0.8 (mariadb-connector-odbc-3.0.8-win32.msi)

If anyone has a chance to try this, we would appreciate some feedback.