Results 1 to 1 of 1

Thread: Error 4525 - Time contains an invalid value

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2009
    Location
    New Zealand
    Posts
    1,519

    Exclamation Error 4525 - Time contains an invalid value

    Hi DAW/Martin,


    More TIME fields issues - now in cDbCJGrid

    We have a DD Structure as per:

    Customer (main_dd)
    --> constrains DIARY (cDbCJGrid #1)
    ----> constrains DBNOTES (cdbTextEdit)
    ------> constrains NOTESITM (cDbCJGrid #2)

    Note: All the cDbCJGrid objects in the view are in a READ_ONLY state, therefore behaves like a LIST

    The view works well, if you move between "DIARY" records or rows in main Grid #1, all related NOTESITM records are displayed on a second Grid #2.

    Works well.

    BUT, it user sorts the second Grid or NOTESITM by the TIME field then you get the following error when you try to move between "DIARY" records/rows in the main GRID #1:

    Code:
    Time contains an invalid value. Table = NOTESITM (75), Field = DT_START (3)
    
    
    Error: 4525
    Error Source = DB2_DRV.Set_Field_Value
    
    
    GET_FINDBYROWIDEX (1761) - oDIARY_DD (8154) - at address 12141
    MSG_ONNOTIFYEXTERNALDDOFSELECT (11225) - oObject (8276) - at address 76866
    MSG_SELECTROW (10425) - oObject (8276) - at address 76850
    GET_ROWCHANGE (11095) - oDiaryGrid (8248) - at address 73181
    MSG_ONCOMFOCUSCHANGING (10206) - oDiaryGrid (8248) - at address 72614
    MSG_ONCOMFOCUSCHANGING (10206) - oDiaryGrid (8248) - at address 120840
    [start] - at address 427624
    Moving record in the child NOTESITM Grid #2 is fine, moving rows in the DIARY Main Grid #1 generates the error above.

    When the Grid #2 is sorted via the TIME field, it uses index #2 with is ID (ascii), DATE (date), DT_START (time), Recnum

    Click image for larger version. 

Name:	TimeGridIssue.png 
Views:	51 
Size:	15.0 KB 
ID:	11723
    What is strange is, if the user sorts NOTESITM grid #2 using any other columns then all is fine - the error only occurs when the time field is sorted.

    Is this a known issue ? If not, please raise a bug report - as the error lies within the runtime

    Thanks.
    Last edited by raveens; 25-Feb-2018 at 11:38 PM.
    Regards,
    Raveen Sundram

    Software Development Manager
    Excellent Software Ltd
    Auckland, New Zealand
    www.xls.co.nz

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •