Geza,

I checked with Cintac and they suggest this might have to do with something server-side other than Dynamic AI, and doubt that somehow forcing charset=iso-8859-2 won't accomplish what you want. Perhaps it has something to do with the database driver being used.

You could test setting some Double-Byte encoding options in report design in case there is some odd interaction with Dynamic AI and the database driver or other server-side O/S component. On the Options tab page in 'Owner Rights' block on lower left is a check box for 'Double-Byte encoding' and also on 'Form Details' tab the 'Type' column for the columns offers an 'encode double byte' options.

Let us know if any of this helps.

Regards,
Bob