Hello Forum,

I have a problem which is similar to thread from June 2015, but the solution proposed there does not work in my case.
I am working with a treeview which has a DbTabDialog connected to it (the treeview is for "navigation" and dbTabDialog is for details and data-entry).
Updating of the DD is done within the "onitemchanged" of the treeview which first finds the record and then sends request_assign to the DD.
In "normal" navigation it Works fine, but when deleting a record -> removing the treeview item -> automatically causing the next item in treeview to be selected the dbtabdialog is empty.

I have augmented the Request_delete in the DD so it:
1) forward sends request_delete
2) Checks that the record is actually deleted
3) Removes the treeview item

I tried for a long time to figure out where it goes wrong, and found that within above step 3 the onitemchanged, which is triggered by removing a treeitem, does find a record but apparently the request_assign sent to the DD has no effect. I tried to replace the request_assign with a FindByRowId but result is the same.
There are no error messages in any of this.

All inputs for further trouble-shooting are appreciated

BR
Carsten