My mistake. I had to go back look at your code. I didn't realize (or remember ) that you are setting the global filters for the entity. Yes, I see now, you are correct.