I am using dataflex 3.1d under SCO unix using Ansi emulation.

I am trying to transition to a new menu program based on the sample code provided by data access.

When I run the program the initial top row of menu options displays correctly.

When I use the left and right arrows, the current item in scope is wiped out.

I traced the escape sequences, and dataflex is sending ^[[47mSales, the "47" color is the same color as the top line of the menu, so the Sales text disappears!

This same behaviour occurs when navigating through the menus with the up and down keys.

I have tried changing the colors in the program specified by these lines:

Integer Color_Fore Color_Back // Set three default colors Fore, back & Hi
Integer Color_hi // Fore and back work best as 1 & 2
Move 1 to Color_Fore // Hi is used to set the color of the footer ba.

Move 2 to Color_Back // It should normally be a reverse or highlight.
Get Palette_Color 1 2 to Color_Hi // We use the Selected color of the standard // palette for this.

But I haven't been able to get it to work.

I was also wondering how to get rid of the background - DF is changing the graphics mode then outputting a series of 0 characters:

H^[[12m^[[40m^[[37m00000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000000

Where is this controlled?

The following include code is used:

Use Case.mac
Use VMenu
Use VAction
//Use Help
Use Timer
Use destobj

Use Error

Can these modules be changed?

The menu program I am trying to use has this in its revision history at the top:

//02/27/95 JJT - Check_Flx was not trimming args correctly!

I'm including it here in case someone recognizes the code and has worked with it, or can suggest a more up to date sample to work with.

Thanks so much.