Hi DAW,


Another suggestion to consider in the medium-long term.

With VDF17, the DD source has lost some of its nice structure and auto-comments. In VDF11, the Define_Field method (now called Construct_Object) had a very nice and readable structure, with section comments and field name comments too! I understand with the new Studio DD-modeller, this is not possible or even should be done.

I suggest writing the DD field-base properties with padded spaces to at least align the "FIELD" keyword.

Here is an example of how a field properties are written:

Code:
    Set Field_Label_Long Field Supp.Supp To "Supplier"
    Set Field_Label_Short Field Supp.Supp To "Code"
    Set Field_Option Field Supp.Supp DD_AUTOFIND to True
    Set Field_Option Field Supp.Supp DD_REQUIRED to True
    Set Field_Option Field Supp.Supp DD_CAPSLOCK to True
    Set Field_Prompt_Object Field Supp.Supp to SUPP_SL
    Set Key_Field_State Field Supp.Supp to True
    Set Status_Help Field Supp.Supp To "Supplier Code"

    Set Field_Option Field Supp.Name DD_CAPSLOCK to True
    Set Status_Help Field Supp.Name To "Supplier Name"
It would be nice if the field properties were written as follows:

Code:
    Set Field_Label_Long    Field Supp.Supp to "Supplier"
    Set Field_Label_Short   Field Supp.Supp to "Code"
    Set Field_Option        Field Supp.Supp DD_AUTOFIND to True
    Set Field_Option        Field Supp.Supp DD_REQUIRED to True
    Set Field_Option        Field Supp.Supp DD_CAPSLOCK to True
    Set Field_Prompt_Object Field Supp.Supp to SUPP_SL
    Set Key_Field_State     Field Supp.Supp to True
    Set Status_Help         Field Supp.Supp to "Supplier Code"

    Set Field_Option        Field Supp.Name DD_CAPSLOCK to True
    Set Status_Help         Field Supp.Name to "Supplier Name"
This just makes it more readable and identifying field sections easier.

Thanks.