VDF 17.0 rc & the MSSQLDRV version that comes with it.
Windows 7 x64 machine with SQLExpress

I'm trying to enumerate the tables from a MS SQL database on my machine that is a SQLExpress database.
I can login and connect to the SQL db and enumerate the databases without any problems.

However, when trying the function EnumerateTables it always returns zero (0).

Because Windows Authentication is used there is no UID or Password. So I tried first (after the login & enumeration of databases) to pass UID="" and Password="" to the EnumerateTables function - no luck. Then I tried to add a ";Trusted_Connection=Yes" right after the "SERVER=xxx" - but still no luck.

So the second variant of what was passed to the EnumerateTables function is as follows:
"DRIVER={SQL Server};SERVER=NILS-W510\SQLExpress;Trusted_Connection=Yes;UID=;PWD=;D ATABASE=Test"

Oh, I might add that I have set the psDriver to MSSQLDRV_ID of the cCLIHandler object prior calling the function.

What is going on here? Anybody knows?

TIA.