Are there recommended replacments for these messages in cDbCJGridPromptList?

Regarding the first, may i suggest a hook in MoveValueOut or ClosePromptList such as onMovevalueOut which would be passed the invoking object. May i also suggest that the term display_buffer_msg not be used and replaced with a more meaningful name.

Perhaps the Prompt_Callback could be a hook in InitializePromptList