Search:

Type: Posts; User: Mike Peat

Page 1 of 79 1 2 3 4

Search: Search took 0.03 seconds.

  1. Replies
    8
    Views
    238

    Re: Parse 'nested' JSON

    Benjamin - I wrote a little tool that may help - see: https://support.dataaccess.com/Forums/showthread.php?65503-cJsonPath-class.

    Mike
  2. Replies
    31
    Views
    853

    Re: DataFlex Styler testing 1-2-3

    ;)
  3. Replies
    31
    Views
    853

    Re: DataFlex Styler testing 1-2-3

    Burn the witch! Burn the witch! ;)

    Mike
  4. Re: cWebTreeView setting colour of an item - red / green / normal

    Archie

    How are you loading the tree view? In OnLoadChildNodes, yoiu can do something like (untested):


    If (somethingOK) ;
    Move "someGreenCSSClass" to aItems[i].sCSSClass
    Else If...
  5. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    :d:d:d:d:d
  6. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    At least I can now stop trying to make sense of the gibberish output of WireShark/tcpdump that I've been staring at all morning! Massive relief! :)
  7. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Michael

    Genius! How the **** did you work that out?

    Like you said - it now just works!

    Thank you! :)

    Mike
  8. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Wil

    Looks OK from that PoV:
    14661

    Now... tell me how to use freekin' WireShark... I used to know, but I've obviously forgotten. :(

    Mike
  9. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Hmm... Wireshark wanted an update and is now taking forever doing it. :(
  10. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    OK, here is what - after extensive testing - seems to be happening. The behaviour is different on my Win7 and Win10 VMs using essentially the same code:

    Win10:

    First call on running the...
  11. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Vincent

    Yes, heard about that on the news this morning... but I don't think so. It is still exhibiting the same behaviour this morning, which I will detail below.

    Mike
  12. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Marco

    No, the Headers are being cleared and reset on every call. Why would that be an issue?

    Mike
  13. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Michael

    That's the thing - when it fails, there is no response from PayPal. When it works I get:


    {
    "scope": "https://uri.paypal.com/services/invoicing...
  14. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    However, if Fiddler is running, it works first time, but Fiddler pops up:
    14660

    From Fiddler:



    # Result Protocol Host URL Body Caching Content-Type Process ...
  15. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Samuel

    On further investigation it turned out to be no such thing. ;)

    The first call always seems to fail, but all subsequent calls work. I'm thinking of it like this...

    It needs an HTTPS...
  16. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Addendum...

    It doesn't work on the first call, but does on subsequent calls... just doubling the HttpVerbAddrRequest line gives a result.

    Not sure why yet...

    Mike
  17. Replies
    26
    Views
    433

    Re: PayPal get token call not working

    Michael

    Well that was spooky! Installed Fiddler Classic on my Win10 VM... Set psProxy in my HttpTransfer object to "127.0.0.1:8888", and... the darn thing just worked. Commented out the psProxy...
  18. Replies
    26
    Views
    433

    PayPal get token call not working

    Hi all

    I've been trying to help Edgar with a PayPal call. It is defined here.

    As it shows on that page, the following curl command works (on my Win7, Win10 and Mac - I had to replace ' with "...
  19. Re: Share project codebase between DF 19.x and 20.0

    Stephen

    Just looking at that I spotted a minor typo:
    14654

    Missing closing parenthesis - ")" - at the end of the line.

    Mike
  20. Re: Share project codebase between DF 19.x and 20.0

    Luca

    I'd suggest that if you want a single code-base (sensible) you do any editing in the DF19.1 Studio and only use the DF20.0+ Studio for compiling those versions. I would think that would work...
  21. Replies
    5
    Views
    231

    Re: DR runtime not installing on server

    Hi Vincent

    Just to let you know, the new version - 8.0.1b - did what it said on the tin and solved my problem.

    Thank you! :)

    Mike
  22. Replies
    5
    Views
    231

    Re: DR runtime not installing on server

    Thanks Vincent

    Mike
  23. Replies
    12
    Views
    316

    Re: Attempt to create in a protected table.

    Sandy

    Why do you have a Log DD at all? Why do you have the Log table marked as an "external"?

    Just remove any reference to it from the A table DD and get rid of the Log DD and it should work,...
  24. Replies
    5
    Views
    231

    Re: DR runtime not installing on server

    Thanks Vincent. :)
  25. Replies
    5
    Views
    231

    DR runtime not installing on server

    Vincent

    Re:

    Is there any fix in the works for this? The customer needs to be able to print from the server, which because of this they can't. Is there a manual work-around?

    Mike
Results 1 to 25 of 1953
Page 1 of 79 1 2 3 4