View RSS Feed

Development Team Blog

Windows 2003 Test Environment: Getting rid of a few Annoyances

Rating: 13 votes, 5.00 average.
Depending on what you are working on, certain improvements in security that Microsoft implemented become annoyances in your test environment. On Windows Server 2003, my favorite two that I need to turn off immediately are:

1. Internet Explorer Enhanced Security Configuration
2. Shutdown Event Tracker


1. Internet Explorer Enhanced Security Configuration
By default, this is enabled on Windows 2003. Whenever you open IE, you get the message below displayed in the browser:
Microsoft Internet Explorer's Enhanced Security Configuration is currently enabled on your server. This enhanced level of security reduces the risk of
attack from Web-based content that is not secure, but it may also prevent Web sites from displaying correctly and restrict access to network resources.
No website displays correctly, or should I say at all? You may add the sites to the trusted list, but then another page requires other things to be enabled and it may become a never-ending configuration job. When opening Database Explorer, for example, if you have the "Did you know" dialog enabled, the contents will be blocked too.



In a test environment, this is one of the first things I have to turn off in order to move on and test what I really need to test. If you want to do the same:
  • Open Control Panel, click Add or Remove Programs
  • Click Add/Remove Windows Components from the sidebar
  • Click on Internet Explorer Enhanced Security Configuration to clear the selection
  • Click Next, and then click Finish.
You will need to restart Internet Explorer to apply the changes.


2. Shutdown Event Tracker
When you select to shut down the machine, by default Windows Server 2003 brings up the following dialog:




In a production environment it may make sense to have that dialog, but in a test environment where you need to install and uninstall different components and restart the machine multiple times, that is just a time waster.



In order to get rid of that dialog, you need to use the Group Policy Object Editor Console (gpedit.msc):
  • Go to Start | Run
  • Type gpedit.msc
  • Press OK
  • Expand Computer Configuration | Administrative Templates | System from the tree
  • Locate "Display Shutdown Event Tracker" on the right-pane and double-click on it
  • From the dialog that displays, select Disable under the Settingtab
  • Click OK
You will need to force an update (gpupdate /force) or restart your machine to make the change go into effect.

Good, after turning those two things off, I can start working.


References
Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	ShutdownEventTracker.JPG 
Views:	1395 
Size:	33.1 KB 
ID:	3760   Click image for larger version. 

Name:	DBE- DidYouKnowBlocked.JPG 
Views:	1143 
Size:	40.3 KB 
ID:	3765  

Comments