View Full Version : Key F7 - Studio behavior is strange

7-Mar-2022, 08:33 AM
Sorry, I'm Brazilian. Maybe my English is not so good.
Please, open the attachments. I think I uploaded correctly. Or not?

When a project is running and I press F7 key, I'd like to activate/deactivate WebApp Designer, as Studio is supposed to do. But it doesn't happen.
Instead of that, when I press F7 key, some buttons are enabled/disabled (according to the attachments).

It happens when the project is running.

If the project is not running, F7 key activates/deactivates WebApp Designer normally.

I mean: I have to stop the project to show WebApp Designer.

Do you know why it happens?

Dennis Piccioni
7-Mar-2022, 09:52 AM
Hi Douglas,

I don't see this here. F7 works when I'm debugging or not. I tried in 19.0 and 20.1.

Does it change depending on which window is active or has the focus?

7-Mar-2022, 12:46 PM
Hi, Dennis!
No, it doesn't depend on the focus.
If I run the project, F7 doesn't work. Only that.

Some time ago F7 worked normally. But suddenly it stopped working.

7-Mar-2022, 12:55 PM
Problem solved.
I had inverted my monitors because I changed my place. And Studio "had got lost"... :-)
I had to invert the monitors again, and move the WebApp designer from other screen to other.

Dennis Piccioni
7-Mar-2022, 04:06 PM
I'm glad you figured it out!