View Full Version : DF19/2017 cWebGrid Weird Jumping FF/Chrome

Pascal Ried
3-Feb-2017, 07:59 AM
[Edit: Second March of 2017]
Resolved with DF 19.0 Alpha2 - no weird jumping anymore.

Hey there,

Thanks for all the additions and changes made to DataFlex 2017 so far.

I noticed some weird behaviour for the cWebGrid in Chrome and FireFox.
I first saw it in DF18.1 WebApps and now tested it in the WebOrder of DF19 WebApps.

If the current selected row is not in view (because of scrolling), selection of any row above will not work with mouse clicks.
In DF18.1 (and I thnik 18.2, too) the Grid will also "swallow"/hide some entries above (they just vanish).

Reproducing Steps in the Demo:
1. Start WebOrder of DF19 Examples.
2. Go to Views > Order Entry
3. Select an order and go to the grid.
4. Enter at least 5-10 more than the grid can show without scrolling (depends on monitor size)
-> For me: 22 entries with a WebGrid-Height of 509px (data-dfobj=oOrder.oWebMainPanel.oDetailGrid) showing 15 entries w/o scrolling.
5. scroll down to the end and select the last entry (click into the "Description" or "Price" column of the row)
6. Scroll up and try to select the top-most row (click into the "Description" or "Price" column of the row)
-> It should jump down to the prev. selected row (or even to an "append-new-row"-row) at the bottom.
7. Repeat step 6 (endlessly)

The only way to get to the other row for me is to
A: Clear All / Clear the Grid
B: Use UP/DOWN Keys
D: "Click my way up" After jumping down, don't scroll and select one further up. Then scroll up a bit and repeat.

- It doesn't matter which Theme is used (I mainly tested Flat Desktop and Web Creme)

Anyone else having problems with this or a way to fix/change this?
I manually changed this with a subclass of the client-class df.WebGrid - but it's more a workaround than a real solution.
-> My guess was to supress some .focus() methods.
I don't think this is wanted.

Any reply highly appreciated.

3-Feb-2017, 09:53 AM
I just tested in the weborder and it indeed happens. I also tested in my webapp in 18.2 and it also happens. Bad bad!

Plus, I would like to ask:
When are we going to get horizontal scrollbars in cwebgrid, this is very very important IMHO. This should be added in 19.

Harm Wibier
6-Feb-2017, 03:46 AM
Maybe I am missing the point, but I am not seeing it.

Chris Spencer
6-Feb-2017, 05:23 AM
I reported this a while back. Did a search but could not find my original post, but have definitely seen this

Harm Wibier
6-Feb-2017, 08:24 AM
I think I see it now, you mean when you are in the 'new row' ?

Pascal Ried
6-Feb-2017, 08:45 AM
Hey Harm,

Yes in the new row. Or in any row at the bottom.
The key is, that you have to scoll up so the currently selected row is not visible (beneath the grid, so to say) and then to select a row at the top of the grid (or at least above the currently selected row).
Then it should jump back to the previously selected row or (sometimes) even into the 'new row'.

Pascal Ried
7-Feb-2017, 04:00 AM
Hey there again,

I made a GIF so I and others can maybe see what I meant.
The cursor is where I clicked (the last frame shows where the cursor is and you see at the bottom, that the wrong row is selected)

Made with the 18.2 demo at http://demo.dataaccess.eu/dataflexreportslive/

Harm Wibier
15-Feb-2017, 09:11 AM
I am still not able to reproduce, but we have done some major changes on the WebGrid (refactored a lot to accomodate some new features) that will be in the next Alpha. Let me know if you still see the behavior then..

Pascal Ried
15-Feb-2017, 09:53 AM
Hey Harm,

thanks for the info.
I will test it in the next alpha - where do I find informations about new alpha-releases? Via newsletter?

I will also attend the next Drive-In in Frankfurt in March and maybe there I can show it to Vincent.

Harm Wibier
16-Feb-2017, 09:55 AM
You'll at least see it on the forum here. But I guess we'll notify customers through our other channels (flexlinks, website, facebook, ...) as well.

Showing it to Vincent would not hurt. Although you'll hopefully have the new Alpha by then.. ;)

Pascal Ried
2-Mar-2017, 03:01 AM
Tested it in DF 19.0 Alpha 2 and it works now - no weird jumping anymore.
Thanks, DAW.