PDA

View Full Version : alpha2 Error 5120



jceoms
22-Apr-2014, 09:06 AM
We were using normal beta1

removed beta1 and beta2 installed.

We started getting the error below

---------------


Target: WebServiceDispatcher.wso
Full URL: /weborder/WebServiceDispatcher.wso/CallAction/JSON
Status code: 500
Status text: Internal Server Error


--------------------------------------------------------------------------------

Server Error in Application "DEFAULT WEB SITE/WEBORDER"
Internet Information Services 7.5

Error Summary
HTTP Error 500.0 - Internal Server Error
There is a problem with the resource you are looking for, so it cannot be displayed.
Detailed Error Information
Module IsapiModule
Notification ExecuteRequestHandler
Handler AboMapperCustom-92555
Error Code 0x8007007e

Requested URL http://127.0.0.1:80/weborder/WebServiceDispatcher.wso/CallAction/JSON
Physical Path C:\DataFlex 18.0 Examples\WebOrder\AppHtml\WebServiceDispatcher.wso \CallAction\JSON
Logon Method Anonymous
Logon User Anonymous

Most likely causes:
The path to the ISAPI Filter is incorrect.
IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
IIS was not able to process configuration for the Web site or application.
The authenticated user does not have permission to use this DLL.

Things you can try:
Ensure that the path to the ISAPI DLL is correct.
Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
Check the event logs to see if any additional information was logged.
Verify the permissions for the DLL.
Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

Links and More InformationThis error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.
View more information

Microsoft Knowledge Base Articles:

294807

jceoms
22-Apr-2014, 09:11 AM
where I wrote alpha2 understand beta2

Dennis Piccioni
22-Apr-2014, 09:13 AM
Please see this KBase article (http://www.dataaccess.com/kbasepublic/KBPrint.asp?ArticleID=2469).

jceoms
22-Apr-2014, 09:16 AM
i using windows 7 32 bits

Dennis Piccioni
22-Apr-2014, 09:20 AM
It should apply to Windows 7, as well.

jceoms
22-Apr-2014, 09:24 AM
this is ok in my iis setting
Expand Internet Information Services | World Wide Web Services | Application Development Features

Stephen W. Meeley
22-Apr-2014, 09:38 AM
What location did you use to install beta 2 and what location did the old beta 1 use? Were both installed on the same machine?

jceoms
22-Apr-2014, 09:40 AM
the beta1 has been removed, restart the computer and installed the beta2

jceoms
22-Apr-2014, 09:47 AM
web appcheck is all ok

Stephen W. Meeley
22-Apr-2014, 09:50 AM
Ok, but what was the specific location (drive and path) you had beta 1 installed in and did you use the same location for beta 2 or something different?

jceoms
22-Apr-2014, 12:40 PM
1- i removed beta1
2- i install beta2

Stephen W. Meeley
22-Apr-2014, 12:52 PM
Sorry for the confusion - what I'm looking for is the specific directory you installed to - even if you simply accepted the default locations. On my machine, that default location would be "C:\Program Files (x86)\DataFlex 18.0" but I don't want to make any assumptions about your system.

jceoms
22-Apr-2014, 01:33 PM
solve the problem, install windows again
and beta2
Now everything is working