PDA

View Full Version : Undefined



Roel Westhoff [W4]
22-Nov-2006, 01:15 PM
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.

Eddy Kleinjan
23-Nov-2006, 05:28 AM
Hi Roel,

The 'undefined' message should be translated into a DataFlex Error message. The fact it is showing 'undefined' instead of the real message is a bug in the Library. We've identified that, and will make it available as soon as possible.

The fact that you get the error in the first place is probably because something is not right :-). My guess is that is has something to do with the .wo it is or should be connecting to. Some questions that might get you going:

- Does the .wso run fine? Yours is probably called 'BreService.wso' since you've based your app on the sample. Just enter the address of the ..wso in your browser and it should show you the web service test page.

- Can you query the .wso? Try to enter the object name of you .wbo in the ServiceMetaData function call of the BreService.wso.

- Does the name of the WebObject in the .asp file match the one you have in the .wbo?

I hope this get's you going. If not, please let us know.

Data Access Europe
Eddy Kleinjan
"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> wrote in message news:4P$R1ImDHHA.3272@dacmail.dataaccess.com...
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.

Chris Stammen
23-Nov-2006, 06:33 AM
I'm getting the exact same error. Followed the instructions from the PDF, and tried to get it work on my own table. But it is just showing the 'Undefined' error message. The shortcut keys aren't working either.
I just played around with the wso-tester. BreService.wso is working fine. But when I enter the object name of my .WO (without the required session key!?) the soap returns this:

<iNumber>913</iNumber>
<iLine>14140</iLine>
<sTableName />
<sColumnName />
<sErrorText>Application Data Service is not supported by WebObject: oParentEntry</sErrorText>

-Chris

"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> schreef in bericht news:4P$R1ImDHHA.3272@dacmail.dataaccess.com...
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.

Roel Westhoff [W4]
23-Nov-2006, 03:38 PM
Eddy,

I'm getting the same errors as Chris and got the following result after adding the oSwift object into the

<?xml version="1.0" encoding="utf-8" ?>
- <TBreServiceMetaData>
- <tGlobalSettings>
<sDateMask />
<sDecimalSeparator />
<iDate4_State>0</iDate4_State>
<iEpoch>0</iEpoch>
</tGlobalSettings>
<aTableMetaData />
<aUserData />
- <aErrors>
- <TBreError>
<iNumber>913</iNumber>
<iLine>13982</iLine>
<sTableName />
<sColumnName />
<sErrorText>Application Data Service is not supported by WebObject: oSwift</sErrorText>
</TBreError>
</aErrors>
</TBreServiceMetaData>

No session key added

I also checked the asp file and i can not find any strange things.

W4 Software & Consultancy BV
Roel Westhoff


"Eddy Kleinjan" <eddy.kleinjan@dataaccess.nl> schreef in bericht news:pIEwpouDHHA.1700@dacmail.dataaccess.com...
Hi Roel,

The 'undefined' message should be translated into a DataFlex Error message. The fact it is showing 'undefined' instead of the real message is a bug in the Library. We've identified that, and will make it available as soon as possible.

The fact that you get the error in the first place is probably because something is not right :-). My guess is that is has something to do with the .wo it is or should be connecting to. Some questions that might get you going:

- Does the .wso run fine? Yours is probably called 'BreService.wso' since you've based your app on the sample. Just enter the address of the ..wso in your browser and it should show you the web service test page.

- Can you query the .wso? Try to enter the object name of you .wbo in the ServiceMetaData function call of the BreService.wso.

- Does the name of the WebObject in the .asp file match the one you have in the .wbo?

I hope this get's you going. If not, please let us know.

Data Access Europe
Eddy Kleinjan
"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> wrote in message news:4P$R1ImDHHA.3272@dacmail.dataaccess.com...
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.

Eddy Kleinjan
23-Nov-2006, 08:43 PM
This probably means that your oParentEntry object is based on the 'normal' cWebBusinessProcess class instead of the cBreWebBusinessProcess class that is designed to work with this framework.

Can you please confirm if this is the case?

Eddy Kleinjan
Data Access Europe


"Chris Stammen" <Chris@jds.nl> wrote in message news:aYRJINvDHHA.2584@dacmail.dataaccess.com...
I'm getting the exact same error. Followed the instructions from the PDF, and tried to get it work on my own table. But it is just showing the 'Undefined' error message. The shortcut keys aren't working either.
I just played around with the wso-tester. BreService.wso is working fine. But when I enter the object name of my .WO (without the required session key!?) the soap returns this:

<iNumber>913</iNumber>
<iLine>14140</iLine>
<sTableName />
<sColumnName />
<sErrorText>Application Data Service is not supported by WebObject: oParentEntry</sErrorText>

-Chris

"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> schreef in bericht news:4P$R1ImDHHA.3272@dacmail.dataaccess.com...
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.

Roel Westhoff [W4]
25-Nov-2006, 07:22 AM
Eddy,

Thanks, this solves the problem.
Until the next "challenge' putting 2 related grids on one screen

Roel
"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> schreef in bericht news:bP7Mi9zDHHA.1700@dacmail.dataaccess.com...
Eddy,

I'm getting the same errors as Chris and got the following result after adding the oSwift object into the

<?xml version="1.0" encoding="utf-8" ?>
- <TBreServiceMetaData>
- <tGlobalSettings>
<sDateMask />
<sDecimalSeparator />
<iDate4_State>0</iDate4_State>
<iEpoch>0</iEpoch>
</tGlobalSettings>
<aTableMetaData />
<aUserData />
- <aErrors>
- <TBreError>
<iNumber>913</iNumber>
<iLine>13982</iLine>
<sTableName />
<sColumnName />
<sErrorText>Application Data Service is not supported by WebObject: oSwift</sErrorText>
</TBreError>
</aErrors>
</TBreServiceMetaData>

No session key added

I also checked the asp file and i can not find any strange things.

W4 Software & Consultancy BV
Roel Westhoff


"Eddy Kleinjan" <eddy.kleinjan@dataaccess.nl> schreef in bericht news:pIEwpouDHHA.1700@dacmail.dataaccess.com...
Hi Roel,

The 'undefined' message should be translated into a DataFlex Error message. The fact it is showing 'undefined' instead of the real message is a bug in the Library. We've identified that, and will make it available as soon as possible.

The fact that you get the error in the first place is probably because something is not right :-). My guess is that is has something to do with the .wo it is or should be connecting to. Some questions that might get you going:

- Does the .wso run fine? Yours is probably called 'BreService.wso' since you've based your app on the sample. Just enter the address of the ..wso in your browser and it should show you the web service test page.

- Can you query the .wso? Try to enter the object name of you .wbo in the ServiceMetaData function call of the BreService.wso.

- Does the name of the WebObject in the .asp file match the one you have in the .wbo?

I hope this get's you going. If not, please let us know.

Data Access Europe
Eddy Kleinjan
"Roel Westhoff [W4]" <roel.westhoff@wesmoll.com> wrote in message news:4P$R1ImDHHA.3272@dacmail.dataaccess.com...
Hello development team,

Base: order entry sample Ajax
Accomplishment: I'm trying to create a new item based on the salesperson.asp
Actions: I created a new table and datadictionairy. I've copied the salesperson.asp, salespersonlist.asp to swift.asp and swiftlist.asp (renaming the the names in salesperson.asp ) I've added swift.asp to the menu system
Attached: swift.asp , swiftlist.asp, swift.dd, swift.fd, default.asp

Problem: I get the message 'úndefined' when starting the item but i can not find out where the problem comes from.